Hammond X5 Organ Repair and Installing the FlatKeys FK50240 Top Octave Synthesiser Chip PT2

Well here is part 2 of the Hammond X5 organ repair. After fixing all the issues that were addressed in the first post ill first post the list of problems identified so far that haven’t yet been fixed.

  • Half the key wouldn’t work
  • Percussion on the pedals made awful noises if and when present
  • There didn’t seem to be and difference in note on the keys that worked
  • Sometimes it would make a god awful bang.

Well the last problem on the list was the one I fixed first. As soon as I tried to check the voltages on the power supply it became blatantly obvious what was causing it. One of the wires, when touched, would reproduce the issue and seemed to move in the hold it was connected to inside the PCB.

Hammond psu

The wire in question is the orange wire, which provides the +15 volts to the preamplifier board and is marked +B1. After removing and touching up the solder joints the banging had gone, but when going back to check the voltages -B12, that is supposed to be -27, was fluctuating like mad on my meter. I’ve seen this before and if I would have got my oscilloscope out to check I would guess there would be some severe ripple on -27 volts. When you see your meter fluctuating, it is this ripple that is confusing the multimeter and can sometimes be measured with the ac setting. I didn’t do this because it was a pretty certain bet that capacitor C10 100uf at 35v next to transistor Q3 in the top middle of the picture above was bad.

Here is the schematic of the Hammond X5 Power supply.

x5 psu schem

As can be seen in the picture, this capacitor has the job of smoothing out the ripple on the -27 volt line. After this capacitor was replaced the meter read a steady -26.8 volts which is damn near -27. After a quick check of all the other voltages I was happy that I could move on and was hoping this had fixed a lot of the other problems and hadn’t created any.
Well sadly that hopeful optimism was short lived as it only seemed to fix the banging noise. The circuits that the -27 volts fed must not really care about ripple or may even have local smoothing and even regulation that means that the ripple was a not an issue. Either way it is better that it’s fixed. Now I started looking for the reason why only half the keys worked.
I first started pushing and pulling the connectors to see if the problem was just a bad connection but as soon as I pushed a connector on the amplifier and reverb drive board, sparks seemed to come from underneath. After pulling the board out this is what I found.

chip stuck to back of pcb

Now ignore the bodge wire job, these are common in old equipment. I was more interested in the chip hanging on to the PCB for dear life. It was a 74LS93 4 bit binary counter. I was starting to think this could be the issue with the notes not changing and the keys not working as an organ such as the Hammond works by generating a tone and dividing it up to make each individual note, as far as I understand (I do stand to be corrected). This was leading me to think that the binary counter could be used in part of this division so I started to look for where it may have come from. Sadly this idea fell flat when not a single chip socket was found to be unpopulated, but this does tell me that somebody may have been here to fix this exact same issue before me and more than likely, caused further damage.
The only 74LS93 I could find was on the MDD generator board. This board is also where the -27 volts from the power supply go.

MDD gen board hammond

The two chips at the top of the board are MM5832 and MM5833. They are responsible for dividing the clock down into its respective notes. Looking at this part of the schematic it started to reveal that maybe the issue was with the missing keys.

MDD part schem

As we can see the two chips to the right of the schematic (IC2 and IC3) are nicely labelled to show which note each output produces. As the note IC3 corresponded to the keys that wouldn’t play, I was pretty confident I was onto something. Before I cracked out the oscilloscope I decided that I would check IC1, the only 74LS93 I could find on the board that was the same as the chip found earlier in the repair. This is the response I got from my Wellon programmer that also doubles as a logic tester.

hammond x5 7493 test

To no surprise, the one I found under the board gave a similar result. I was hoping that the two top level octave divider chip had survived and this was the only casualty. The thing that I kept thinking about was the problem with the -27 volt supply. I think that the problem with the supply had taken the chip out and then was replaced hence why I found one floating around under the PCB.
I got my oscilloscope out and looked for an output from the MM5832 and MM5833 with signals looking good on the input. One was outputting a signal, but the other was stone cold dead. I looked at the schematic and decided that switching these two chips would alternate the keys that function (all be it out of tune). This test confirmed that the IC3 was dead.
This was a bit of a setback as these chips have been out of production now for quite some time. Luckily a bit of internet searching lead me to a website call FlatKeys owned by a guy called Chris Burrell who makes and sells logic replacements for these chips. He also deals with an assortment of other hard to replace chips for organs and sells them at a very reasonable price. The added bonus was with the FlatKeys FK50240 top octave synthesiser chip I could also add a transpose switch and an octave switch to give the X5 some new sounds that the original was incapable of (think of the start of Stargazer by Rainbow….well that was the only one I could do).
I asked Chris if he could send me an example of it fitted to an X5 and almost immediately got an email back showing just that.

flatkeys install exampleAs we can see here the replacement has two ribbon cables that go to the MDD board and plug straight into the sockets where the old chips lived.

This gave me confidence that this was the right move and rang the owner of the X5 to see how he would like to proceed. This was greeted with excitement and he quickly ordered the parts and within a few days brought them round to the workshop for me to install.

The kit came with a small circuit board with the ribbon cables already attached in a black project box all screwed together for safe transport. Along with this there was a multi-position rotary switch that was already wired up to an octave switch. This was attached to a plug for an easy install and a transpose switch again connected to a plug. As this kit is made for various organs and keyboards no mounting holes have been drill so firstly I set about drilling and cutting the project box.

flatkeys lid

Here you can see I’ve cut a slot for the ribbon cable and a cutaway for the switch plugs. It could have been a bit nicer but I didn’t have a file handy. I also at this point drilled some pilot holes to hold the box to the back of the organ.

flat keys box installed without lid

This is with the box and board installed and switches plugged in ready to test before fitting the lid. Before I moved on and got to testing there was a little modification that needs to be made to the MDD board before the FK50240 will work in and X5

flatkeys install MDD mod

This is the install modification that Chris sent me that has to be made before moving on. As you can see R12 has to be replaced with a wire link and R13 removed. I could have just put a jumper over R12 and snipped R13 out to make life easy but I decided that I would do it proper and make it look good.

MDD with resistors marked

The photos I took after the modification were all blurry so in the picture above I’ve added two coloured arrows. The green arrow points to the resistor R12. This one needs replacing with a wire link or jumper. The yellow arrow points to R13 and that needs removing from circuit.
After the MDD board has been modified all that is left to do is remove the MM5832 and MM5833 from their sockets and insert the respective plug from the FK50240 (these for me were handily labelled).

 

Flatkey install without controls

Here is a picture of my install as you can see I pretty much copied the example given to me by FlatKeys. After this I hooked up the controls and gave it a quick test. At this point all the keys jumped back to life and I moved onto finding places for the new controls. Me not being well up on playing organ I decided it was best to contact the organs owner and asked for some direction.
Ill wrap it up here and finish this off hopefully with a part 3.

 

Advertisements

4 comments on “Hammond X5 Organ Repair and Installing the FlatKeys FK50240 Top Octave Synthesiser Chip PT2

  1. Mark van Stokkom says:

    Hello,
    Is there perhaps any video material available where I can hear the X5?
    And where did you put the knobs for transposing or octave switching?

    Kind regards,
    Mark

    • krisanks says:

      I’ve no video but there are a few on YouTube although YouTube doesn’t seem to do justice in my opinion when it comes to music. I think this is more down to how people record stuff as most people put things up as a hobby and are on a budget financially and time wise.

      As for the extra knob I placed it to the right in between the other controls. The switched are mounted in the metal just to right and above the knobs.

  2. Klaus Joter says:

    Hi,

    nice work! You put a lot of accuracy and affection into your project. Really love it.
    I have an opportunity of buying a broken X5. I like the sound and as the organ looks old fashioned it would fit to a stage project where every musician should play vintage instruments and amps. So my question: Do you think that it could be repaired at a reasonable price (several tones are not working, reverb seems to be broken as well)? And could the keyboards be midified?
    I would need that, as I should play bass sounds with my left hand. I think the organ is worth it as it still looks very good due to the fact that It was always carried around in a big flightcase. And it is complete – with note stand, bass pedals and the chrome stand. It´s a real challenge to me whether to do it or not! So I would appreciate your good advice.

    Best Regards,
    Klaus
    (Germany)

    • krisanks says:

      There could be a simple reason for certain tones not working or it it could be on of the logic chips as died it’s hard to say. These organs can quickly become a real load of trouble. Without a oscilloscope and an understanding of what you should expect to see it can be hard to diagnose but the manuals I found online had all this info in them it’s just hard to digest. As for modifying it if you mean changing what keys trigger what sounds then that can get quite messy and I would steer away from doing that unless you have lots of time on your hands. Either way I would fix the organ before any attempt at modifying it.

      Regards Kris

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s